Plugin inspection:

iframe

Potentially unsafe

Last revised:

Confidence: Medium
This plugin has been given a short, targeted code review.

Before using this plugin, you should very carefully consider its potential problems and should conduct a thorough assessment. Read more about this recommendation.

Warnings

This recommendation applies to version 3.0 of this plugin, but the most recent version is 5.0. These findings may no longer be correct.

Findings

This plugin is vulnerable to multiple Cross-Site Scripting (XSS) vulnerabilities

Reason for the 'Potentially unsafe' result

The plugin contains or is likely to contain a vulnerability which could be exploited by an end user and which would compromise the site’s confidentiality, integrity or availability:

This plugin includes two vulnerabilities:

Failure criteria

  • Lack of input sanitisation
  • Unsafe request processing

Read more about our failure criteria.