Plugin inspection:

PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus

Use with caution

Last revised:

Confidence: Medium
This plugin has been given a short, targeted code review.

Before using this plugin, you should carefully consider these findings. Read more about this recommendation.

Warnings

This recommendation applies to version 2.3.2 of this plugin, but the most recent version is 2.6.0. These findings may no longer be correct.

Findings

This plugin has a large codebase, including code concerned with Pro version features and legacy versions. It is therefore difficult to fully review, but no issues were found. There are a number of workarounds to handle Gutenberg editor features, so it is recommended to keep the plugin updated in case it is updated to reflect WordPress updates to editor functionality.

Ensure administrator access to modify roles and capabilities is managed (the plugin does protect against dashboard lockout and provide backup/restore options for configuration).

 

Reason for the 'Use with caution' result

The plugin has been given this recommendation at the tester's discretion:

The plugin appears safe to use from this basic review, but is rated use with caution due to the size and complexity of the code base.

Failure criteria

  • Very large codebase

Read more about our failure criteria.